Handbrake 1.2.0 by wyprzedzić epokę

W obliczu nieuchronnego twórca konwertera wideo Handbrake zrobił co musiał. Podczas gdy wielu użytkowników nadal spiera się z deweloperami, co by tu poprawić w bibliotekach GTK+3.xx, on przygotował się już na GTK+4. Jednak to nie ta dalekowzroczność jest najważniejsza w najnowszym wydaniu Handbrake 1.2.0.

Tytułowego konwertera nie trzeba chyba nikomu przedstawiać. A już na pewno jego zagorzałym fanom. Niemniej, jeżeli ktoś zamierza pracować na najnowszej wersji musi wziąć pod uwagę kilka zaistniałych faktów.

Handbrake 1.2.0 – wygląda niepozornie

    Ogólnie

  • biblioteka Libav zastąpiona przez FFmpeg, kompletnie

  • usunięte przestarzałe ustawienia wstępne,

  • zaktualizowano ustawienia aby używały stereo zamiast dotychczasowego miksowania DLP2,

  • poprawki w ustawieniach umożliwiające współpracę z nowymi urządzeniami,

  • automatyczna translacja Fire TV na Amazon Fire,

  • dodano zestaw gotowców dla Amazon Fire 720p30 oraz Chromecast 1080p60,

  • {creation-date} i {creation-time} dla wspomożenia automatycznego nazewnictwa,

  • zapoczątkowane wsparcie dla GTK+4

  • Wideo

  • naprawiono problemy z dekodowaniem materiału Blu-ray z nieznanymi proporcjami (teraz domyślnie 16:9),

  • naprawiono problemy z kodowaniem wideo z bardzo krótkimi odstępami pomiędzy klatkami (mniej niż 0.00285s),

  • ulepszono obsługę nadmiarowych danych aby dopasowały się do każdego kodeka,

  • wsparcie dla wideo TIFF/LZMA,

  • Audio

  • naprawiono potencjalne problem z dekodowaniem nie do końca poprawnie zdefiniowanego audio,

  • naprawiono potencjalny błąd podczas próbkowania audio,

  • ulepszono resampling umożliwiający dither dla wszystkich kodeków,

  • poprawiono jakość dekodowania AAC,

  • kolejne ulepszenie umożliwiające jakość 6kbit/s na kanał dla formatu Opus,

  • wsparcie dla dekodowania AAC 7.1,

  • wsparcie dla formatu E-AC3 w plikach MP4,

  • dekoder Speex,

Ta niebagatelna lista zmian to rzecz jasna bardzo powierzchowny spis tego co najważniejsze. Dociekliwi dotrą do znacznie dokładniejszych wniosków na podstawie fachowego rozpoznania programu.

Aby przetestować program w Ubuntu 18.04/18.10, Mincie 19.xx i pochodnych należy skorzystać z repozytorium PPA:

sudo add-apt-repository ppa:stebbins/handbrake-releases
sudo apt-get update
sudo apt-get install handbrake-gtk

Program znajdziemy również w głównym repozytorium Arch Linuksa i Manjaro:

sudo pacman -Suy handbrake
 

Kto czyta, ten wie:

Dodaj komentarz