Wtyczka Crayon Syntax Highlighter Obsługa PHP 8.0 oraz 8.1

Poniższy poradnik opisuje sposób naprawy wtyczki Crayon Syntax Highlighter do wordpress.
Wtyczka domyślnie nie jest przygotowana do obsługi php 8 więc trzeba to naprawić samemu.

Generalnie całość rozgrywa się o edycję 1 pliku:

Edytujemy plik wtyczki w katalogu naszego wordpressa

/wp-content/plugins/crayon-syntax-highlighter/util/crayon_util.class.php

I około 73 linijki zmieniamy :

$lines = implode($lines, $delimiter);

Zmieniamy na :

$lines = implode($delimiter, $lines);

Dodaj komentarz